Vulnerability Exposes F5 BIG-IP to Kerberos KDC Hijacking Attacks

Vulnerability Exposes F5 BIG-IP to Kerberos KDC Hijacking Attacks

F5 Networks this week released patches to address an authentication bypass vulnerability affecting BIG-IP Access Policy Manager (APM), but fixes are not available for all impacted versions.

Tracked as CVE-2021-23008, the high-severity vulnerability allows for the bypass of BIG-IP APM AD (Active Directory) authentication if the attacker can hijack a Kerberos KDC (Key Distribution Center) connection using a spoofed AS-REP (Kerberos Authentication Service Response).

Authentication bypass is also possible from an AD server that the attacker has already compromised, F5 explains. The attacker could also bypass policies and gain unfettered access to sensitive workloads, according to identity protection firm Silverfort, whose researchers discovered the vulnerability.

“In some cases this can be used to bypass authentication to the Big-IP admin console as well,” the researchers say.

The Kerberos protocol leverages a client-server model for on-premise authentication, with KDC being an intermediary that holds shared secret keys and user access information. When attempting to access a resource, the KDC prompts for a username and password and also checks if the user has privileges to access that resource.

For the protocol to work, the user and the KDS authenticate to the server and the server authenticates to the client. If the Kerberos KDC authentication to the server is compromised, the attacker can hijack the connection between the client and the domain controller, thus bypassing authentication.

Such attacks typically exploit misconfigurations in Kerberos protocol implementations, and the same applies to F5 BIG-IP as well. Thus, an attacker can create a domain controller with a username identical to the admin’s username and target the flaw to authenticate to BIG-IP even if they do not know the correct password, by hijacking the KDC connection.

“For an APM access policy configured with AD authentication and SSO (single sign-on) agent, if a spoofed credential related to this vulnerability is used, depending how the back-end system validates the authentication token it receives, access will most likely fail. An APM access policy can also be configured for BIG-IP system authentication. A spoofed credential related to this vulnerability for an administrative user through the APM access policy results in local administrative access,” F5 notes.

BIG-IP APM versions 11.5.2 through 16.0.1 are known to be vulnerable. Fixes were included in BIG-IP APM versions 12.1.6, 13.1.4, 14.1.4, and 15.1.3, but no patches are available for the 11.x and 16.x branches.

As for mitigations, F5, which also credits Thierry Van Steirteghem from Exclusive Networks for reporting the vulnerability, suggests enabling multi-factor authentication (MFA), or host-level authentication.

This week, the company also released patches for a medium-severity vulnerability in BIG-IP APM (CVE-2021-23016) that could be abused to bypass internal restrictions and retrieve static content stored within APM.

Related: Researchers Raise Alarm for F5 BIG-IP Malware Attacks

Related: F5 Patches Four Critical Bugs in Big-IP Suite

Related: Vulnerability Exposes F5 BIG-IP Systems to Remote DoS Attacks

picture 142

Ionut Arghire is an international correspondent for SecurityWeek.

Previous Columns by Ionut Arghire:
tag iconTags:

Source link

LEAVE A REPLY

Please enter your comment!
Please enter your name here